1

Closed

Requirements

description

Hi,
 
What Visual Studio and DotNet versions are supported?
Closed Feb 11, 2011 at 9:11 PM by StanislawSwierc
The new release contains binaries for all supported versions. It would be worth to create a short tutorial demonstrating how to configure the project to build it against something different from 4.0. I'm closing this issue and I creating a new task for the tutorial.

comments

StanislawSwierc wrote Feb 6, 2011 at 6:01 PM

I'm sorry that you had to wait for the reply so long. I didn't want to reply earlier as I would have to tell that its only 4.0. Luckily on 03.02.2011 I had some time to work at it and now I can list more frameworks.

AsyncFunc supports .NET Framework versions:
  • 2.0
  • 3.0
  • 3.5
  • 4.0
If you want to compile it against some older versions you need to do it on your own. However it is pretty simple. I edited the proj file manually and added all necessary configurations. You just need to go to Configuration Manager in Visual Studio and choose the version you want. All the binaries will be placed in the correct folders like "bin\2.0\Debug\" and so on.

As for VS I'm using 2010 but you can use 2008 as well. If you want to use the same proj file you just need to edit ToolsVersion attribute in the second line. You need to change it from "4.0" to "3.5" or even lower depending on the version of your MSBuild. I will probably prepare proj files for SV 2008 once I find one.

wrote Feb 11, 2011 at 9:11 PM

wrote Feb 13, 2013 at 8:26 PM

wrote May 16, 2013 at 5:13 AM